Archinect
anchor

AutoCAD > Illustrator > pdf! Lineweights lost in translation?

040690

Hi all,

I've been working on putting my portfolio together recently, and have encountered a miniscule problem that I can't solve for some reason. Anyway, what happens is, I have a floorplan in autoCAD, which I printed to pdf and opened in Illustrator, then printed to pdf again along with other images. The problem is, the lineweights of my line drawings (e.g. plans, sections, etc.) look really thick and the same when viewed at 100%-250% scale in adobe acrobat pro, and it's not until I zoom to 400% when I can tell the differences in lineweight. Any thoughts or suggestions? Thanks in advance!

 
Apr 21, 09 12:59 am
Minimal Animal

You should print the autocad plans to EPS using your preferred lignweights. Then open the EPS file in Illustrator. This will give you crisp vector format objects that you can then save/export however you want from Illustrator.

Apr 21, 09 1:09 am
holz.box

you can import acad directly into illustrator... why print as EPS?

Apr 21, 09 1:56 am
cowgill

.eps works well.

also, when you save the .dwg in autocad, the CURRENT layer states (what's hidden/frozen/on-off, & what's not) is saved and imported into illustrator as such. If layer "X" in autocad is hidden when saved, it is not placed into the Illustrator workspace. If layer "X" is visible, then it IS placed into Illustrator.

In order to preserve the layer structure, I will sequentially save the autocad file in between placing it into Illustrator with the desired layers on or off... before the desired layer in the .dwg is placed into illustrator, make a new layer in Illustrator and put the freshly imported objects there... rinse and repeat and you'll have an Illustrator file that mirrors your Autocad layer structure.

...doing this allows you to select an entire layer at a time and tweak line weights accordingly.

Apr 21, 09 7:49 am
freeezerburn

you can bring dwgs directly into illustrator. so what you can do is set each lineweight to a unique color, then when you paste the dwg into illustrator, click a line, then select similar color, then set the color/lineweight for all lines of that color.

you can do this for all the unique line colors that you brought in from cad.

Apr 21, 09 9:59 am
trace™

Don't you experience problems with curves being too faceted?


Apr 21, 09 10:03 am
cowgill

...adjust the display resolution in Acad

options>display tab>display resolution settings

Apr 21, 09 10:06 am
jesaku

The actual answer to this question is that Acrobat just simplifies to speed up its display. Go to preferences and change your settings; the information on line weights is still there.

Apr 21, 09 11:10 am
wbnetter

Thanks a lot jesaku, I always wondered why Acrobat does that! It's ruined many a presentation at my school.

Apr 21, 09 1:08 pm
maya mcdifference

"In order to preserve the layer structure, I will sequentially save the autocad file in between placing it into Illustrator with the desired layers on or off... " NOT NECESSARY!

You can open your .dwg (without printing .eps file) in Rhino and you should have all your layers there. Once you import the drawing as an AI file you should see all the layers once you open the file in Illustrator.

so...Autocad>Rhino>Illustrator

Apr 21, 09 6:30 pm
hndhmn

Thank you so much, this work so well

maya mcdifference

I meant that you have to export your drawing from Rhino as an AI file...

Apr 21, 09 6:31 pm
040690

Wow all great suggestions...I'm gonna work on trying every one of them. Thanks so much!

I do have one more question concerning jesaku's reply...excatly which preference setting should I tinker with? I've been playing around with that and don't seem to find the right category for the lineweight display.

Apr 21, 09 8:32 pm
wbnetter

Go to Edit>Preferences>Page Display. Then uncheck "enhance thin lines" And it should solve your problem...it fixed mine.

Apr 21, 09 8:36 pm
placebeyondthesplines_

And then just hope whoever is looking at your portfolio has that option checked too...

PodZilla

If you're using Illustrator CS3 and your acad layers are being removed or condensed into one illustrator layer, you need to download the UPDATED plugin so that it maintains the layers when the file is imported. They (adobe) changed this from cs2 to cs3, it used to be layers came in automagically, then in cs3 they didn't until people complained and they changed the plugin. I don't have time to search for it now but its buried somewhere on the adobe site. download it and replace the current importer plugin with it and all should be well... acad dwg's can come straight into illustrator with all layers intact.

Apr 21, 09 8:39 pm
PodZilla
hndhmn

thanks for sharing this link, but I see there's no link or any download button in this page.. so what's the matter?

I'm using Ai CC 2018, should I download this plugin to fix the layers issue?

cowgill

thanks Pod!

Apr 30, 09 2:04 pm
hndhmn

What version do you use?
I'm using Ai CC 2018, and the issue still exists,
I check the link that provided by @PodZilla but I didn't find a download button and it says for CS3...

can someone help with this?
I wan't to import .dwg to Ai with its layers.

Jan 13, 18 2:39 pm
placebeyondthesplines_

Try saving your .dwg as an AutoCAD 2007 file. You should be able to open that in CC2018.

Block this user


Are you sure you want to block this user and hide all related comments throughout the site?

  • ×Search in: