Archinect
anchor

SketchUp help - kind of an emergency

Jul 18 '13 10 Last Comment
Donna SinkDonna Sink
Jul 18, 13 8:07 am

Hey All: I have a SU model that was given to me by another department.  I added in the tall tower-like object we are planning to build.  But when I change the Style, the upper 2/3 of the entire model disappear - it must have something to do with the Layers things are drawn on? The only way I've been able to make the upper 2/3 reappear is to close w/o saving. 

Is there any way to adjust the Style but not have my work disappear from view?! It's not really an emergency, but I have a meeting tomorrow morning before which I'd like to get the Style looking better.

 

hatchline
Jul 18, 13 8:17 am

That's strange, Styles shouldn't have any effect on layers.  Is the tower object on a separate layer?  Also, when you say disappears, is it completely missing, or does it look like the viewport is being clipped?

gruen
Jul 18, 13 8:31 am

Check if components are on one layer, but if you drill into them they are drawn on a different layer. Check status of "color by layer". If you have a view tab set up, it might be activating layers on/off when you change something, so try saving a new view when it looks good then changing the style.

b3tadine[sutures]
Jul 18, 13 8:38 am

are you sure it's not a clipping plane issue?

Jonathan CulpJonathan Culp
Jul 18, 13 9:05 am

It could either be a section plane (view > uncheck section cuts) or the file has become too large for the graphics to be displayed and so SketchUp has this weird clipping that happens (try saving and quitting [and other unnecessary programs running in the background] then re-open it). 

gwharton
Jul 18, 13 12:08 pm

Without seeing the actual model or screenshots, I'd say it's probably a section plane issue. Styles control whether section planes are turned on or not in a view. If there is a section plane embedded in a component or group defining the tower, switching to a style which has section planes activated with cut off the top of the tower without cutting anything else. Note that by embedding section planes in groups/components, you can have multiple section planes cutting at the same time.

Clipping plane issues are seen more with view/zoom parameters when switching back and forth between perspective and parallel projection modes, and are more related to the size of the model in the coordinate space. That doesn't sound like what your problem is.

Donna SinkDonna Sink
Jul 18, 13 12:34 pm

Ok, Johnathan Culp, we're on to something.  When I CHECK Section Cuts, the same part of the model disappears as when I change the Style to anything new.  When I uncheck it, the model looks normal.

So if I pick the Style I want, then uncheck Section Cut and Plane, it all comes back.  Thank you!

backbay
Jul 18, 13 10:41 pm

maybe the lines were hidden somehow?  "edit > unhide" maybe?

nycdesigns
Jul 19, 13 1:38 am

I would also look to see if you have any hidden geometry. Goto View>Hidden Geometry (make sure this is checked.

Can you simply use another style?

Donna SinkDonna Sink
Jul 19, 13 12:11 pm

Strange, but no matter what I check or unchecl in View, when I go to Styles and click any Default Style the hidden stuff goes away.  So if I set it on the Style I want, then uncheck Section Cut and Section Plane, all is well.

Thank you for your help everyone! I think I nailed the meeting, though I'm not sure if it was the renderings or that I was in agreement with the boss that makes me feel like it went well LOL!

gwharton
Jul 19, 13 12:18 pm

Did you edit the style so that sections are turned off? In the Styles window, click the Edit tab, then the Modeling icon (the little blue box under the tab). You'll see a bunch of check boxes for section planes, hidden geometry, etc. Play around with those. When you get it the way you want, make sure you click on the style icon in the upper left corner (it will have a grey circular arrow superimposed on it). That will save your changes and update the style definition.

  • ×Search in:


Please wait... loading
Please wait... loading